It is currently Mon Apr 21, 2014 10:38 am

Contact Us | All times are UTC + 1 hour




Welcome
Welcome to Dayz Patriots!

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements. Registration is fast, simple, and absolutely free, so please, join our community today!


Post new topic Reply to topic  [ 230 posts ]  Go to page 1, 2, 3, 4  Next
Author Message
 Post subject: Admin tools [ 1.7.7.1 ]
PostPosted: Wed Mar 20, 2013 10:49 pm 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
///////////////UPDATED, WORKS WITH 1.7.7.1!!!!//////////////////

In this tutorial I'll show you how to add Admin tools like : God mode, teleport, zombie shield etc... to your server. BattlEye tested!

Thanks to BluePhoenix175 for making this script! http://opendayz.net/index.php?members/bluephoenix175.3310/

This script will add:
- ESP / teleport
- God Mode
- Vehicle God Mode
- Fix Buildings
- Spectate Player
- Heal nearby players
- Look-n-repair
- 6 skin options including invisible skin
- weapon kits
- and zombie shield
- vehicle spawning
-teleporting players to you

Special thanks to jasonpointer who updated the script, and helped me getting this working on 1.7.7.1! Profile: http://opendayz.net/members/jasonpointer.6590/

Installation:

1: First download the script from here (1.7.7.1) https://www.dropbox.com/sh/ymwc0j4ln6hrztm/biXnOIhsB-

2: Extract it, and put the "admintools" folder into your root mission folder.

3: Make these changes in your init.sqf

A) at the bottom of init.sqf you can see this:

Code:
// Logo watermark: adding a logo in the bottom left corner of the screen with the server name in it
if (!isNil "dayZ_serverName") then {
   [] spawn {
      waitUntil {(!isNull Player) and (alive Player) and (player == player)};
      waituntil {!(isNull (findDisplay 46))};
      5 cutRsc ["wm_disp","PLAIN"];
      ((uiNamespace getVariable "wm_disp") displayCtrl 1) ctrlSetText dayZ_serverName;
   };
};


above that, insert this code:

Code:
[] execVM "admintools\Activate.sqf";


I will look like this:

Spoiler:
if (!isDedicated) then {
//Conduct map operations
0 fadeSound 0;
waitUntil {!isNil "dayz_loadScreenMsg"};
dayz_loadScreenMsg = (localize "STR_AUTHENTICATING");

//Run the player monitor
_id = player addEventHandler ["Respawn", {_id = [] spawn player_death;}];
_playerMonitor = [] execFSM "admintools\player_monitor.fsm";
//[] execVM "\z\addons\dayz_code\system\antihack.sqf";
};

[] execVM "admintools\Activate.sqf";

// Logo watermark: adding a logo in the bottom left corner of the screen with the server name in it
if (!isNil "dayZ_serverName") then {
[] spawn {
waitUntil {(!isNull Player) and (alive Player) and (player == player)};
waituntil {!(isNull (findDisplay 46))};
5 cutRsc ["wm_disp","PLAIN"];
((uiNamespace getVariable "wm_disp") displayCtrl 1) ctrlSetText dayZ_serverName;
};
};

#include "\z\addons\dayz_code\system\REsec.sqf"


B): Find this code:
Code:
_playerMonitor = [] execVM "\z\addons\dayz_code\system\player_monitor.sqf";


and change it to:
Code:
_playerMonitor = [] execFSM "admintools\player_monitor.fsm";


C): Find this code:
Code:
[] execVM "\z\addons\dayz_code\system\antihack.sqf";


and change it to:
Code:
//[] execVM "\z\addons\dayz_code\system\antihack.sqf";
this will disable the useless DayZ antihack.

6: Place the admin ids into activate.sqf and admintoolsmain.sqf (thanks again jasonpointer!) click on the spoiler:

Spoiler:
Too add UID's

simply open admintools\Activate.sqf
Basically in line 2 just edit in between the brackets add this in
Code:
,"PLAYERID"

E.g :

if ((getPlayerUID player) in ["11111111"]) then {
to
if ((getPlayerUID player) in ["11111111","22222222"]) then {

it will looks like this:

Code:
waituntil {!alive player ; !isnull (finddisplay 46)};
if ((getPlayerUID player) in ["111111","222222"]) then {
    sleep 30;
    player addaction [("<t color=""#0074E8"">" + ("Tools Menu") +"</t>"),"admintools\Eexcute.sqf","",5,false,true,"",""];
};


Also Edit admintools\AdminToolsMain.sqf

Add all UID's like you did above in this line
Line12 if ((getPlayerUID player) in ["111111","222222","333333","444444","555555"]) then { //all admins

Any lines you dont want to allocate anyone then just edit so its like this
LineXX if ((getPlayerUID player) in [""]) then

For basic sub admin, Add in their UiD's here. If not then leave it like above ""
Line13 if ((getPlayerUID player) in ["111111"]) then { //mods

For sub admins, Add their UiD's here. If not blank it like above ""
line23 if ((getPlayerUID player) in ["222222","333333"]) then { //admins

For full admin powers, Add their UiD's. If not blank it like above ""
line33 if ((getPlayerUID player) in ["444444","555555"]) then { // super admins

Hope this is clear enough.


How to get your unique id:
Spoiler:
Profile>>"PlayerName">>Edit, look in the bottom left hand corner for "Player ID" that is the number that needs to be added to the code.


7: Download these BE filters (thanks inkko !) : https://www.dropbox.com/sh/6i87emd336hinsw/0VFA6_kjpP and replace them with your server's BE filters. <--- (Check the "READ ME FIRST" topic, it will help you.)

8: EDIT YOUR DAYZ_SERVER.PBO

Spoiler:
8: Unpack your dayz_server.pbo.

9: Open the server_cleanup.fsm the line you are looking for is either:

Code:
" if (!(vehicle _x in _safety) && ((typeOf vehicle _x) != ""ParachuteWest"") ) then {" \n


change it to:

Code:
" if (!(vehicle _x in _safety) && ((typeOf vehicle _x) != ""ParachuteWest"") && (vehicle _x getVariable ["Sarge",0] != 1) ) then {" \n


or if your code looks like this:

Code:
if(vehicle _x != _x && !(vehicle _x in _safety) && (typeOf vehicle _x) != ""ParachuteWest"") then {" \n


change it to:

Code:
if(vehicle _x != _x && (vehicle _x getVariable ["Sarge",0] != 1) && !(vehicle _x in _safety) && (typeOf vehicle _x) !=


10: Open the server_objectUpdate.sqf and change this

Code:
if (!_parachuteWest) then {
if (_objectID == "0" && _uid == "0") then {
_object_position = getPosATL _object;
diag_log format ["DEBUG: Deleting object %1 with invalid ID at [%2,%3,%4]", typeOf _object, _object_position select 0, _object_position select 1, _object_position select 2];
_isNotOk = true;
};
};


to
Code:
if (!_parachuteWest) then {
   if (_objectID == “0″ && _uid == “0″ && (vehicle _object getVariable ["Sarge",0] != 1)) then {
   {
      _object_position = getPosATL _object;
      #ifdef OBJECT_DEBUG
          diag_log format ["DEBUG: Deleting object %1 with invalid ID at [%2,%3,%4]“, typeOf _object, _object_position select 0, _object_position select 1,
         typeOf _object,
         _object_position select 0,
         _object_position select 1,
         _object_position select 2]);
      #endif
         _isNotOk = true;
   };
};


10: Pack your mission, and server folder and upload it to your server.

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------

If your player ID has been added to the correct portions of code a option will be added to the scroll menu. (It took me like 20 seconds to appear)

FAQ

Spoiler:
Q: I teleported and now I cant move!

A: Press w + space.

Q: How do i return to my body after spectating a player?

A: Press F3.

Q: I executed "script name" and now im stuck, frozen, glitched..ect

A: Change skin to survivor, if that does not work relog.

Q: I want to modify my debug monitor can you help?

A: No, post here http://opendayz.net/index.php?threads/d ... itor.8402/ for help.

Q: I followed the readme to the letter but its not working.

A: Did you set your instance ID # in init.sqf?


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Wed Mar 20, 2013 11:03 pm 
Offline

Joined: Mon Mar 18, 2013 6:38 pm
Posts: 3
Nice... Keep up the good work!


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Tue Mar 26, 2013 7:50 pm 
Offline

Joined: Tue Mar 26, 2013 7:16 pm
Posts: 1
Getting stuck at Auth. Could you come on a teamspeak server possibly? Gimme a quick hand.


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Tue Mar 26, 2013 8:27 pm 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
Hey! I didn't tried it on my server so I can't give you any support yet. Maybe check the original post. http://opendayz.net/index.php?threads/d ... 76/page-13


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Mon Apr 22, 2013 9:28 am 
Offline

Joined: Sat Apr 06, 2013 7:57 pm
Posts: 20
was twisting my head around, looking for what i did wrong, and found it.

_playerMonitor = [] execFSM "admintools\player_monitor.fsm"

_playerMonitor = [] execFSM "admintools\player_monitor.fsm";


Funny how alittle ; can mess it all up:)


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Mon Apr 22, 2013 1:15 pm 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
Yes, every comma is important :)


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Fri Apr 26, 2013 3:48 pm 
Offline

Joined: Fri Apr 26, 2013 3:46 pm
Posts: 8
I'm having a problem with adding the admin tools I added the player id's and that but when I go in-game to test if it worked the commands wont show up I was just wondering if you could help me


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Fri Apr 26, 2013 7:58 pm 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
send me your mission.pbo


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Fri Apr 26, 2013 8:42 pm 
Offline

Joined: Fri Apr 26, 2013 3:46 pm
Posts: 8
ok i have sarges AI as well, http://www.mediafire.com/?k019bmex15ldboo


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Sun Apr 28, 2013 5:24 pm 
Offline

Joined: Fri Apr 26, 2013 3:46 pm
Posts: 8
ive only been implementing scripts for a couple of days sorry to be a bother


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Tue Apr 30, 2013 11:09 pm 
Offline

Joined: Tue Apr 30, 2013 11:07 pm
Posts: 1
It seems that when I try to join the game, I do not load in and get stuck on Loading Character Data, Please wait


Top
 Profile  
 
 Post subject: Re: Admin tools help
PostPosted: Fri May 03, 2013 11:28 pm 
Offline

Joined: Fri May 03, 2013 11:21 pm
Posts: 3
I have followed the instructions an have yet to get the extra menu. i have added my uid to the id spot and have tried my player id aswell.

could some one help me by chance?
i am running sarge A.I and trying to add admin controls.

runing on taviana 2.0 .com one (not the .eu)

willing to donate to some one if they could make me misson and server pbo that contains sarge A.I, admin controls, debug monitor. lol also dogs if they work....


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Sat May 04, 2013 1:31 pm 
Offline
User avatar

Joined: Fri May 03, 2013 4:39 pm
Posts: 71
Location: Germany
Same here....installed all fine but no scroll Menu appears in Game.
Using DayzCC on Cherno Map.
It would be great when someone can help me :P

EDIT: Got an Answer here ---> KLICK,
i will try that and give feedback soon as possible!!

Greetz Ace

_________________
Image
VISIT US HERE ROTTENHIVE
[DE] .:|RoTTen RusT|:. | [Essentials][PVP][Sleeper][Airdrops][Forum][Active Admins][No Cheat] net.connect 31.214.240.124:28100


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Fri May 10, 2013 8:12 pm 
Offline
User avatar

Joined: Fri May 03, 2013 4:39 pm
Posts: 71
Location: Germany
Hey Guys its me again
The Tool works great, but i use now this Anticheat Scan script ah.sqf
And now the Admin Tools Menu dont shows up
What can i do to get both working?!

Thanks alot!!

Greez Ace

_________________
Image
VISIT US HERE ROTTENHIVE
[DE] .:|RoTTen RusT|:. | [Essentials][PVP][Sleeper][Airdrops][Forum][Active Admins][No Cheat] net.connect 31.214.240.124:28100


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Fri May 10, 2013 9:11 pm 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
Hey! It does not work with the anti-cheat script. I checked it, and they said it's impossible.


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Fri May 10, 2013 9:43 pm 
Offline
User avatar

Joined: Fri May 03, 2013 4:39 pm
Posts: 71
Location: Germany
HMMMMM.... its not nice to hear that :(

_________________
Image
VISIT US HERE ROTTENHIVE
[DE] .:|RoTTen RusT|:. | [Essentials][PVP][Sleeper][Airdrops][Forum][Active Admins][No Cheat] net.connect 31.214.240.124:28100


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Tue May 14, 2013 3:37 pm 
Offline

Joined: Fri Apr 26, 2013 3:46 pm
Posts: 8
The Admin Tools are working fine just wondering about the Teleporting though, when I leftalt+click I Teleport there but as I press W+space it puts me back where I wanted to Teleport from anyone know a solution to this problem?

Kind regards karl


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Thu May 16, 2013 5:26 am 
Offline

Joined: Thu May 16, 2013 5:22 am
Posts: 16
I'm having a bit of trouble, I've followed instructions up to the "Server name here" but the scripts.txt replacement I'm having trouble doing. How do I find and replace?

Thanks.


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Thu May 16, 2013 2:46 pm 
Offline

Joined: Fri Apr 26, 2013 3:46 pm
Posts: 8
FourSevenDelta wrote:
I'm having a bit of trouble, I've followed instructions up to the "Server name here" but the scripts.txt replacement I'm having trouble doing. How do I find and replace?

Thanks.


Who is your server provider?


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Thu May 16, 2013 10:15 pm 
Offline

Joined: Thu May 16, 2013 3:55 am
Posts: 7
Hmm, can't get the scroll menu to appear.


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Fri May 17, 2013 12:06 am 
Offline

Joined: Thu May 16, 2013 5:22 am
Posts: 16
Karl wrote:
FourSevenDelta wrote:
I'm having a bit of trouble, I've followed instructions up to the "Server name here" but the scripts.txt replacement I'm having trouble doing. How do I find and replace?

Thanks.


Who is your server provider?
DayZ.ST


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Fri May 17, 2013 4:09 pm 
Offline

Joined: Fri Apr 26, 2013 3:46 pm
Posts: 8
Ok then to find the scripts.txt you need an ftp program like core ftp or something like that then on your admin panel you should have the ftp details on the left copy and paste that into the ftp in the connect option


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Fri May 17, 2013 4:48 pm 
Offline

Joined: Fri May 17, 2013 1:54 pm
Posts: 1
Hi all scripts for battleye do not work.Getting kicked and another thing that does not work is the vehicles menu i tried it without battleye,vehicles disappear but if u get on them they explode and you die.Can anyone give me a good scripts.txt and the admin tools working,please?I am using DayZ CC.


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Fri May 17, 2013 7:54 pm 
Offline

Joined: Thu May 16, 2013 5:22 am
Posts: 16
Karl wrote:
Ok then to find the scripts.txt you need an ftp program like core ftp or something like that then on your admin panel you should have the ftp details on the left copy and paste that into the ftp in the connect option
OK thanks, that's all replaced.

What happens to the admintoolsmain.sqf and the debug playerstats.sqf files that were in the admin tools file I downloaded and put my player ID in?

Thanks again for your help.


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Fri May 17, 2013 9:54 pm 
Offline

Joined: Fri Apr 26, 2013 3:46 pm
Posts: 8
FourSevenDelta wrote:
Karl wrote:
Ok then to find the scripts.txt you need an ftp program like core ftp or something like that then on your admin panel you should have the ftp details on the left copy and paste that into the ftp in the connect option
OK thanks, that's all replaced.

What happens to the admintoolsmain.sqf and the debug playerstats.sqf files that were in the admin tools file I downloaded and put my player ID in?

Thanks again for your help.


they are fine mate you dont need to do anything to them btw you are welcome ;)


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Fri May 17, 2013 10:04 pm 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
The link is for the new version of the admin tools, but actually I don't like it, and it seems it's harder to get it work. I'll post a link directing to the older one, me and the other people that I helped use that prerfectly.


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Fri May 17, 2013 10:27 pm 
Offline

Joined: Thu May 16, 2013 5:22 am
Posts: 16
Ok, I've made the changes to the mission.pbo and then replaced it on my admin panel but when I try to join it just says "wait for host".
Also, you mention packing the mission.pbo but the pbo view says "It seems that it isn't Arma PBO" so I just replace it. Could that be causing an issue?


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Sat May 18, 2013 1:55 am 
Offline

Joined: Thu May 16, 2013 5:22 am
Posts: 16
Sorry for the double post.
I've managed to work out how to modify the mission.pbo then repack. When I try and go into my server it now has a 40 second wait on the "loading character data, please wait" screen, then I get in the lobby and it says "Script debug\playerstats.sqf not found".

Where am i going wrong? :oops:

Many Thanks.


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Sat May 18, 2013 11:09 am 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
Are you using the script without the debug monitor? Try the debug monitor version.


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Sat May 18, 2013 11:15 am 
Offline

Joined: Thu May 16, 2013 5:22 am
Posts: 16
Yes I'm using the debug version. Should I be putting the admin tools download somewhere in particular?


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Sat May 18, 2013 1:14 pm 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
you have to put the "debug" and the "admintools" folder into your server's root mission folder.


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Sat May 18, 2013 1:25 pm 
Offline

Joined: Thu May 16, 2013 5:22 am
Posts: 16
I must apologize, where do I find the servers root mission folder?


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Sat May 18, 2013 1:35 pm 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
It's the default folder. The init.sqf, description.ext and the mission.sqf file can be found here. Example if you use dayz.st, when you download the dayz_mission.pbo and unpack it, you will get a dayz_mission FOLDER. That is the root foolder.


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Sat May 18, 2013 2:31 pm 
Offline

Joined: Thu May 16, 2013 5:22 am
Posts: 16
I've put both the admintools and debug folders into the root folder and packed it. I'm now getting in to the server but not seeing the menu.

Thanks again for your help and patience.


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Sun May 19, 2013 11:04 pm 
Offline

Joined: Thu May 16, 2013 5:22 am
Posts: 16
I have it working now, I noticed in the Activate.sqf file there was a bunch of #'s so I changed them to my player ID too and it works. Sorry if I was a pain :)


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Mon May 20, 2013 12:17 am 
Offline

Joined: Mon May 20, 2013 12:14 am
Posts: 1
Cannot get the menu to come in in tools.. Any help plz


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Mon May 20, 2013 12:51 am 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
UPDATE COMING SOON!


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Mon May 20, 2013 5:05 am 
Offline

Joined: Thu May 16, 2013 5:22 am
Posts: 16
JSteinkush wrote:
Cannot get the menu to come in in tools.. Any help plz
Are you getting the tools menu come up at all when you scroll the mouse wheel?


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Wed May 22, 2013 9:18 pm 
Offline

Joined: Thu May 16, 2013 3:55 am
Posts: 7
I've followed all the steps and still can't get it to work, Hoplit, can you take a look at my PBO for me?


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Wed May 22, 2013 9:58 pm 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
I'm going to update the download link, it will work with that :)


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Wed May 22, 2013 10:55 pm 
Offline

Joined: Thu May 16, 2013 3:55 am
Posts: 7
Well I've got everything worked out, except it's just not showing.


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Thu May 23, 2013 5:26 pm 
Offline

Joined: Thu May 16, 2013 5:22 am
Posts: 16
How do I teleport myself? Can't seem to work it out.


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Thu May 23, 2013 9:42 pm 
Offline

Joined: Thu May 23, 2013 9:41 pm
Posts: 2
i can log on but am not getting the option when i am scroling, culd anyone help me please?


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Thu May 23, 2013 9:54 pm 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
I'm doing a 1 day break because I'm sick, but after that I can help you! :)


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Thu May 23, 2013 10:04 pm 
Offline

Joined: Thu May 23, 2013 9:41 pm
Posts: 2
so tomorrow?:D


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Fri May 24, 2013 5:37 pm 
Offline

Joined: Thu May 16, 2013 5:22 am
Posts: 16
Worked out tele.
Anyone know what each of these numbers represent on the debug?
Example:
Vehicles: 87(128)

Maybe 87 total vehicles but what is the number in brackets?

Many thanks.


Top
 Profile  
 
 Post subject: Re: Admin tools
PostPosted: Fri May 24, 2013 7:31 pm 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
TUTORIAL UPDATED, TRY NOW IF IT DIDN'T WORK BEFORE!


Top
 Profile  
 
 Post subject: Re: Admin tools [ UPDATED 2013.05.24]
PostPosted: Fri May 24, 2013 8:00 pm 
Offline

Joined: Fri May 24, 2013 7:50 pm
Posts: 5
I've followed everything here and no menu pop-up

I'm using a dayz.st server (@bliss1122)
I added the missing ; to the end of

_playerMonitor = [] execFSM "admintools\player_monitor.fsm"

as well as added my UID over the ######

but still no additional menu. I don't get the last part about the script.txt...
Do I overwrite the server (via FTP) with the one I downloaded from github?

init.sqf
Code:
/*   
   INITILIZATION
*/
startLoadingScreen ["","RscDisplayLoadCustom"];
cutText ["","BLACK OUT"];
enableSaving [false, false];

//REALLY IMPORTANT VALUES
dayZ_instance = 1122;               //The instance
dayzHiveRequest = [];
initialized = false;
dayz_previousID = 0;

//disable greeting menu
player setVariable ["BIS_noCoreConversations", true];
//disable radio messages to be heard and shown in the left lower corner of the screen
//enableRadio false;

//Load in compiled functions
call compile preprocessFileLineNumbers "\z\addons\dayz_code\init\variables.sqf";            //Initilize the Variables (IMPORTANT: Must happen very early)
progressLoadingScreen 0.1;
call compile preprocessFileLineNumbers "\z\addons\dayz_code\init\publicEH.sqf";            //Initilize the publicVariable event handlers
progressLoadingScreen 0.2;
call compile preprocessFileLineNumbers "\z\addons\dayz_code\medical\setup_functions_med.sqf";   //Functions used by CLIENT for medical
progressLoadingScreen 0.4;
call compile preprocessFileLineNumbers "\z\addons\dayz_code\init\compiles.sqf";            //Compile regular functions
progressLoadingScreen 1.0;

"filmic" setToneMappingParams [0.153, 0.357, 0.231, 0.1573, 0.011, 3.750, 6, 4]; setToneMapping "Filmic";
playerstats = compile preprocessFileLineNumbers "debug\playerstats.sqf";

if ((!isServer) && (isNull player) ) then
{
waitUntil {!isNull player};
waitUntil {time > 3};
};

if ((!isServer) && (player != player)) then
{
  waitUntil {player == player};
  waitUntil {time > 3};
};

if (isServer) then {
   _serverMonitor =    [] execVM "\z\addons\dayz_code\system\server_monitor.sqf";
};

if (!isDedicated) then {
   //Conduct map operations
   0 fadeSound 0;
   waitUntil {!isNil "dayz_loadScreenMsg"};
   dayz_loadScreenMsg = (localize "STR_AUTHENTICATING");
   
   //Run the player monitor
   _id = player addEventHandler ["Respawn", {_id = [] spawn player_death;}];
   _playerMonitor = [] execFSM "admintools\player_monitor.fsm";
};
[] execVM "admintools\Activate.sqf";


debug\playerstats.sqf
Code:
//Let Zeds know
[player,4,true,(getPosATL player)] spawn player_alertZombies;

if (isnil ("hotkey_hitme")) then {
    hotkey_hitme = 0;
};
if (hotkey_hitme == 1) then {
hotkey_hitme = 0;
titleText ["Debug Monitor Deactivated","PLAIN DOWN"];titleFadeOut 2;
} else {
hotkey_hitme = 1;
titleText ["Debug Monitor Activated","PLAIN DOWN"];titleFadeOut 2;
};

/*
Change the UID's below to match those of you and your admin(s)
Your admins will get the advanced version of your debug monitor,
while your regular users will get the cut down version.
*/

if ((getPlayerUID player) in ["######","######"]) then {     
   while {sleep 1;hotkey_hitme == 1} do {
     hintSilent parseText format ["
   <t size='0.95' font='Bitstream' align='left' >[%18]</t><t size='0.95' font='Bitstream' align='right'>[FPS: %10]</t><br/>
   <t size='0.95' font='Bitstream' align='center' color='#FFBF00'>Survived %7 Days</t><br/>
   <t size='0.95' font='Bitstream' align='left' >Players: %8</t><t size='0.95 'font='Bitstream' align='right'>Within 500m: %11</t><br/>
   <t size='0.95' font='Bitstream' align='left' >Vehicles:</t><t size='0.95' font='Bitstream'align='right'>%13(%14)</t><br/>
   <t size='0.95' font='Bitstream' align='left'>Air: %16</t><t size='0.95' font='Bitstream'align='right'>Sea: %23</t><br/>
   <t size='0.95' font='Bitstream' align='left' >All Bikes: %15</t><t size='0.95' font='Bitstream'align='right'>Cars: %17</t><br/>
   <t size='0.95' font='Bitstream' align='left' >Zombies (alive/total): </t><t size='0.95' font='Bitstream' align='right'>%20(%19)</t><br/>
   <t size='0.95' font='Bitstream' align='left' color='#FFBF00'>Zombies Killed: </t><t size='0.95' font='Bitstream' align='right'>%2</t><br/>
   <t size='0.95' font='Bitstream' align='left' color='#FFBF00'>Headshots: </t><t size='0.95' font='Bitstream' align='right'>%3</t><br/>
   <t size='0.95' font='Bitstream' align='left' color='#FFBF00'>Murders: </t><t size='0.95' font='Bitstream' align='right'>%4</t><br/>
   <t size='0.95' font='Bitstream' align='left' color='#FFBF00'>Bandits Killed: </t><t size='0.95' font='Bitstream' align='right'>%5</t><br/>
   <t size='0.95' font='Bitstream' align='left' color='#FFBF00'>Humanity: </t><t size='0.95' font='Bitstream' align='right'>%6</t><br/>
   <t size='0.95' font='Bitstream' align='left' color='#FFBF00'>Blood: </t><t size='0.95' font='Bitstream' align='right'>%9</t><br/>
   <t size='0.95' font='Bitstream' align='left' >GPS: %22</t><t size='0.95' font='Bitstream' align='right'>DIR: %24</t><br/>
   <t size='0.95'font='Bitstream'align='center' >%21</t><br/>",
   (name player),
   (player getVariable['zombieKills', 0]),
   (player getVariable['headShots', 0]),
   (player getVariable['humanKills', 0]),
   (player getVariable['banditKills', 0]),
   (player getVariable['humanity', 0]),
   (dayz_skilllevel),
   (count playableUnits),
   r_player_blood,
   (round diag_fps),
   (({isPlayer _x} count (getPos vehicle player nearEntities [["AllVehicles"], 500]))-1),
   viewdistance,
   (count([6800, 9200, 0] nearEntities [["StaticWeapon","Car","Motorcycle","Tank","Air","Ship"],25000])),
   count vehicles,
   (count([6800, 9200, 0] nearEntities [["Motorcycle"],25000])),
   (count([6800, 9200, 0] nearEntities [["Air"],25000])),
   (count([6800, 9200, 0] nearEntities [["Car"],25000])),
   (gettext (configFile >> 'CfgVehicles' >> (typeof vehicle player) >> 'displayName')),
   (count entities "zZombie_Base"),
   ({alive _x} count entities "zZombie_Base"),
   (getPosASL player),
   (mapGridPosition getPos player),
   (count([6800, 9200, 0] nearEntities [["Ship"],25000])),
   (round(getDir player))
];
};
} else {

while {sleep 1;hotkey_hitme == 1} do {

hintSilent parseText format ["
   <t size='1.20' font='Bitstream' align='center' color='#00CC00'>%1</t><br/>
   <t size='0.95' font='Bitstream' align='center' >[%11]</t><br/>
   <t size='1.15' font='Bitstream' align='center' color='#FFCC00'>Survived %7 Days</t><br/><br/>
   <t size='1.15' font='Bitstream' align='left' color='#FFBF00'>Zombies Killed: </t><t size='1.15' font='Bitstream' align='right'>%2</t><br/>
   <t size='1.15' font='Bitstream' align='left' color='#FFBF00'>Headshots: </t><t size='1.15' font='Bitstream' align='right'>%3</t><br/>
   <t size='0.95' font='Bitstream' align='left' color='#FFBF00'>Murders: </t><t size='0.95' font='Bitstream' align='right'>%4</t><br/>
   <t size='0.95' font='Bitstream' align='left' color='#FFBF00'>Bandits Killed: </t><t size='0.95' font='Bitstream' align='right'>%5</t><br/>
   <t size='1.15' font='Bitstream' align='left' color='#FFBF00'>Humanity: </t><t size='1.15' font='Bitstream' align='right'>%6</t><br/><br/>
   <t size='1.15' font='Bitstream' align='left' color='#FFBF00'>Blood: </t><t size='1.15' font='Bitstream' align='right'>%10</t><br/>
   <t size='1.15' font='Bitstream' color='#5882FA'>HeatproofSean's Server</t><br/>",
   (name player),
   (player getVariable['zombieKills', 0]),
   (player getVariable['headShots', 0]),
   (player getVariable['humanKills', 0]),
   (player getVariable['banditKills', 0]),
   (player getVariable['humanity', 0]),
   (dayz_skilllevel),
   (count entities "zZombie_Base"),
   ({alive _x} count entities "zZombie_Base"),
   r_player_blood,
   (gettext (configFile >> 'CfgVehicles' >> (typeof vehicle player) >> 'displayName'))
];};};


admintools\AdminToolsMain.sqf
Code:
//customise these menus to fit your server
if ((getPlayerUID player) in ["13072006", "13072005", "13072004"]) then { //all admins
   if ((getPlayerUID player) in ["13072005"]) then { //mods
        adminmenu =
        [
         ["",true],
            ["Tools Menu", [2], "#USER:ModToolsMenu", -5, [["expression", ""]], "1", "1"],
            ["Skins Menu", [3], "#USER:SkinsMenu", -5, [["expression", ""]], "1", "1"],
            ["Weapon Kits", [4], "#USER:WeaponMenu", -5, [["expression", ""]], "1", "1"],
            ["", [-1], "", -5, [["expression", ""]], "1", "0"],
         ["Exit", [13], "", -3, [["expression", ""]], "1", "1"]   
        ];};
   if ((getPlayerUID player) in ["13072004"]) then { //admins
        adminmenu =
        [
         ["",true],
            ["Tools Menu", [2], "#USER:AdminToolsMenu", -5, [["expression", ""]], "1", "1"],
            ["Skins Menu", [3], "#USER:SkinsMenu", -5, [["expression", ""]], "1", "1"],
            ["Weapon Kits", [4], "#USER:WeaponMenu", -5, [["expression", ""]], "1", "1"],
            ["", [-1], "", -5, [["expression", ""]], "1", "0"],
         ["Exit", [13], "", -3, [["expression", ""]], "1", "1"]   
        ];};
   if ((getPlayerUID player) in ["13072006"]) then { // super admins
      adminmenu =
      [
         ["",true],
            ["Toggle Debug", [2], "", -5, [["expression", format[_execdebug,"playerstats.sqf"]]], "1", "1"],
            ["Tools Menu", [3], "#USER:ToolsMenu", -5, [["expression", ""]], "1", "1"],
            ["Skins Menu", [4], "#USER:SkinsMenu", -5, [["expression", ""]], "1", "1"],
            ["Weapon Kits", [5], "#USER:WeaponMenu", -5, [["expression", ""]], "1", "1"],
            ["Shields Menu", [6], "#USER:ShieldMenu", -5, [["expression", ""]], "1", "1"],
            ["Vehicle Menu", [7], "#USER:VehicleMenu", -5, [["expression", ""]], "1", "1"],
            ["", [-1], "", -5, [["expression", ""]], "1", "0"],
         ["Exit", [13], "", -3, [["expression", ""]], "1", "1"]      
      ];};
} else {
adminmenu =
[
   ["",true],
      ["Toggle Debug", [2], "", -5, [["expression", format[_execdebug,"playerstats.sqf"]]], "1", "1"],
      ["", [-1], "", -5, [["expression", ""]], "1", "0"],
   ["Exit", [13], "", -3, [["expression", ""]], "1", "1"]
];};


admintools\Activate.sqf
Code:
waituntil {!alive player ; !isnull (finddisplay 46)};
if ((getPlayerUID player) in ["13072006"]) then {
   sleep 30;
   player addaction [("<t color=""#0074E8"">" + ("Tools Menu") +"</t>"),"admintools\Eexcute.sqf","",5,false,true,"",""];
};


Top
 Profile  
 
 Post subject: Re: Admin tools [ UPDATED 2013.05.24]
PostPosted: Fri May 24, 2013 8:08 pm 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
You have to overwrite the existin scripts.txt, and I noticed that you forgot this part in the debug/playerstats:
if ((getPlayerUID player) in ["######","######"]) then {


Top
 Profile  
 
 Post subject: Re: Admin tools [ UPDATED 2013.05.24]
PostPosted: Fri May 24, 2013 8:26 pm 
Offline

Joined: Fri May 24, 2013 7:50 pm
Posts: 5
ok cheers. made the changes and it worked.
But any vehicle spawned via the admin tools despawns (and kills the player if they are inside) in seconds.
Also when I died this way, I couldn't bring up the tools menu. I swapped my pistol for my flashlight and it then worked but after using a weapon kit (M4 CCO SD) the option vanished again.

I'll investigate further. And thanks for the help!


Top
 Profile  
 
 Post subject: Re: Admin tools [ UPDATED 2013.05.24]
PostPosted: Fri May 24, 2013 11:19 pm 
Offline

Joined: Fri May 24, 2013 7:50 pm
Posts: 5
so after futher testing... sometimes the admin tool option doesn't appear until about 10-30sec after respawning...
and after using a weapon kit (FAL did this twice) the tool option vanishes again. swapping weapons worked once, and I think I had to log out and in again.

I'm on a bliss server, and entering any vehicle results in it exploding (much like when you add a vehicle via the map editor and not via the db or the online adminCP).

Finally, the ESP/Tele tool... how do I teleport to players/locations? all it does is add markers where vehicles are to the map (players are showing in the HUD). Is that correct?


Top
 Profile  
 
 Post subject: Re: Admin tools [ UPDATED 2013.05.24]
PostPosted: Fri May 24, 2013 11:59 pm 
Offline

Joined: Thu May 16, 2013 3:55 am
Posts: 7
I'm getting a 'No entry 'bin\config.bin.USER:adminmenu'


Top
 Profile  
 
 Post subject: Re: Admin tools [ UPDATED 2013.05.24]
PostPosted: Sat May 25, 2013 8:47 am 
Offline

Joined: Thu May 16, 2013 5:22 am
Posts: 16
heatproofsean wrote:
so after futher testing... sometimes the admin tool option doesn't appear until about 10-30sec after respawning...
and after using a weapon kit (FAL did this twice) the tool option vanishes again. swapping weapons worked once, and I think I had to log out and in again.

I'm on a bliss server, and entering any vehicle results in it exploding (much like when you add a vehicle via the map editor and not via the db or the online adminCP).

Finally, the ESP/Tele tool... how do I teleport to players/locations? all it does is add markers where vehicles are to the map (players are showing in the HUD). Is that correct?
You teleport as if your placing a waypoint but press Alt instead. That's how I do it. If you can't move after teleporting press space and W together.

Can anyone answer my question? The Vehicle numbers on the debug, what does the number in the brackets represent please?


Top
 Profile  
 
 Post subject: Re: Admin tools [ UPDATED 2013.05.24]
PostPosted: Sat May 25, 2013 1:11 pm 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
FourSevenDelta wrote:
heatproofsean wrote:
so after futher testing... sometimes the admin tool option doesn't appear until about 10-30sec after respawning...
and after using a weapon kit (FAL did this twice) the tool option vanishes again. swapping weapons worked once, and I think I had to log out and in again.

I'm on a bliss server, and entering any vehicle results in it exploding (much like when you add a vehicle via the map editor and not via the db or the online adminCP).

Finally, the ESP/Tele tool... how do I teleport to players/locations? all it does is add markers where vehicles are to the map (players are showing in the HUD). Is that correct?
You teleport as if your placing a waypoint but press Alt instead. That's how I do it. If you can't move after teleporting press space and W together.

Can anyone answer my question? The Vehicle numbers on the debug, what does the number in the brackets represent please?


I think first number is the current numbers of the vehicles on the map. And the second numbers are maybe the number of the spawn points on the server.


Top
 Profile  
 
 Post subject: Re: Admin tools [ UPDATED 2013.05.24]
PostPosted: Wed May 29, 2013 12:17 am 
Offline

Joined: Tue May 28, 2013 5:12 am
Posts: 3
I cant seem to get this to work. Can anyone help?


Top
 Profile  
 
 Post subject: Re: Admin tools [ UPDATED 2013.05.24]
PostPosted: Wed May 29, 2013 5:47 am 
Offline

Joined: Wed May 29, 2013 5:44 am
Posts: 10
Hey I could use a tip...

I have the part with editing the server.pbo and the mission.pbo down. I got all of that coding installed (except: if I am the only admin, do I leave the hashtags in the other empty spots for entering my player code number?)

I just don't understand the ftp to the scripts.txt file part. How do I move all of my downloaded files in there? If I have an auto refuel script, do I just add that line again on the bottom? My files I downloaded open with notepad++ but the scripts.txt opens with just normal notepad.... Do I need to change that? If so how?


Top
 Profile  
 
 Post subject: Re: Admin tools [ NEW FULLY WORKING ]
PostPosted: Wed May 29, 2013 7:00 pm 
Offline

Joined: Wed May 29, 2013 4:20 pm
Posts: 5
Where do you put all the files you downloaded? In what folder?


Top
 Profile  
 
 Post subject: Re: Admin tools [ NEW FULLY WORKING ]
PostPosted: Wed May 29, 2013 9:18 pm 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
into your mission folder. example: dayz_mission


Top
 Profile  
 
 Post subject: Re: Admin tools [ NEW FULLY WORKING ]
PostPosted: Wed May 29, 2013 9:39 pm 
Offline

Joined: Wed May 29, 2013 4:20 pm
Posts: 5
@Hoplit Thank you, must've missed that.
After i have now set everything up, im getting "Authentication Error" and then "something went wrong"
Know what i did wrong?


Top
 Profile  
 
 Post subject: Re: Admin tools [ NEW FULLY WORKING ]
PostPosted: Wed May 29, 2013 10:40 pm 
Offline
Forum Admin
User avatar

Joined: Wed Feb 13, 2013 5:51 pm
Posts: 429
could you upload the content of your init.sqf to pastebin?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 230 posts ]  Go to page 1, 2, 3, 4  Next

Contact Us | All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred